分类
成功交易者的秘密

多周期MACD趋势共振制作的方法.理论

11-28 3139

通达信MACDKDJ多周期指标公式

DIF60:=Ema(CLOSE,12/2)-EMA(CLOSE,26/2);
DEA60:=EMA(DIF60,9/2);
stICKLINE(DIF60>=DEA60,42,46,5,0),COLOR00BBBB;
STICKLINE(DIF60 DRAWTEXT(CURRBARSCOUNT=13,44,'★60分钟macd★'),COLORWHITE;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
STICKLINE(DIF>=DEA,36,40,5,0),COLOR0000BB;
STICKLINE(DIF DRAWTEXT(CURRBARSCOUNT=13,38,'★MacD日线★'),COLOR00FFFF;
周MD:=MACD.DIF#WEEK;
周MA:=MACD.DEA#WEEK;
STICKLINE(周MD>=周MA,30,34,5,0),COLORBB00BB;
STICKLINE(周MD <周MA,30,34,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,32,'★MACD周线★'),COLOR00FFFF;
月MD:=MACD.DIF#MONTH;
月MA:=MACD.DEA#MONTH;
STICKLINE(月MD>=月MA,24,28,5,0),COLORBBBB00;
STICKLINE(月MD <月MA,24,28,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,26,'★月MACD★'),COLORWHITE;
RSV60:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36));
K60:=SMA(RSV60,3,1);
D60:=SMA(K60,3,1);
STICKLINE(K60>= D60,18,22,5,0),COLOR00FFFF;
STICKLINE(K60 < D60,18,22,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,20,'★60分钟kdj★ '),COLORFF00FF;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(K>=D,12,16,5,0),COLOR0000FF;
STICKLINE(K DRAWTEXT(CURRBARSCOUNT=13,14,'★kdJ日线★'),COLORFFFFFF;
周K:="KDJ.K#WEEK" ;
周D:="KDJ.D#WEEK" ;
STICKLINE(周K>=周D,6,10,5,0),COLORFF00FF;
STICKLINE(周K <周D,6,10,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,8,'★KDJ周线★'),COLORWHITE;
月K:="KDJ.K#MONTH" ;
月D:="KDJ.D#MONTH" ;
STICKLINE(月K>=月D,0,4,5,0),COLORFF00FF;
STICKLINE(月K <月D,0,4,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,2,'★KDJ月线★'),COLORWHITE;

MACD多周期共振系统

//------------------------------------------------------------------------ // 简称: MACDRS // 名称: MACD Resonance System // 类别: 交易指令 // 类型: 多头建仓 // 输出: //------------------------------------------------------------------------ Params Numeric FastLength(12); Numeric SlowLength(26); Numeric MACDLength(9); Vars NumericSeries MACDValue1; NumericSeries MACDValue3; NumericSeries MACDValue5; NumericSeries MACDValue15; NumericSeries MACDValue30; Numeric AvgMACD1; Numeric AvgMACD3; Numeric AvgMACD5; Numeric AvgMACD15; Numeric AvgMACD30; Numeric MACDDiff1; Numeric MACDDiff3; Numeric MACDDiff5; Numeric MACDDiff15; Numeric MACDDiff30; Bool LongEntryCon; Bool ShortEntryCon; Bool LongExitCon; Bool ShortExitCon; Begin MACDValue1 = XAverage( Close, FastLength ) - XAverage( Close, SlowLength ); AvgMACD1 = XAverage(MACDValue1,MACDLength); MACDDiff1 = MACDValue1 - AvgMACD1; MACDValue3 = MinsXAverage(3, Close, FastLength ) - MinsXAverage(3, Close, SlowLength ); AvgMACD3 = MinsXAverage(3,MACDValue3,MACDLength); MACDDiff3 = MACDValue3 - AvgMACD3; MACDValue5 = MinsXAverage(5, Close, FastLength ) - 多周期MACD趋势共振制作的方法.理论 MinsXAverage(5, Close, SlowLength ); AvgMACD5 = MinsXAverage(5,MACDValue5,MACDLength); MACDDiff5 = MACDValue5 - AvgMACD5; MACDValue15 = MinsXAverage(15, Close, FastLength ) - MinsXAverage(15, Close, SlowLength ); AvgMACD15 = MinsXAverage(15,MACDValue15,MACDLength); MACDDiff15 = MACDValue15 - AvgMACD15; MACDValue30 = MinsXAverage(30, Close, FastLength ) - MinsXAverage(30, 多周期MACD趋势共振制作的方法.理论 Close, SlowLength ); AvgMACD30 = MinsXAverage(30,MACDValue30,MACDLength); MACDDiff30 = MACDValue30 - AvgMACD30; LongEntryCon = MACDDiff1 > 0 && MACDDiff3 > 0 && MACDDiff5 > 0 && MACDDiff15 > 0 && MACDDiff30 > 0; ShortEntryCon = MACDDiff1 0; 多周期MACD趋势共振制作的方法.理论 Commentary("MACDDiff1="+Text(MACDDiff1)); Commentary("MACDDiff3="+Text(MACDDiff3)); Commentary("MACDDiff5="+Text(MACDDiff5)); Commentary("MACDDiff15="+Text(MACDDiff15)); Commentary("MACDDiff30 article-donate"> 点赞( 0 )

通达信多周期共振MACD指标公式

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:(DIF1-DEA1)*2,COLORSTICK;
DIF11:=EMA(CLOSE,16) - EMA(CLOSE,34.5);
DEA11:=EMA(DIF11,12);
MACD11:(DIF11-DEA11)*2,COLORSTICK;
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));
DIF:=EMA(CLOSE,6) - EMA(CLOSE,13);
DEA:=EMA(多周期MACD趋势共振制作的方法.理论 DIF,4.5);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD11>0,0,MACD11,1.5,0),COLOR8800FF;
STICKLINE(MACD11 <0,0,MACD11,1.5,0),COLORFFFF00;
STICKLINE(MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1 <0,0,MACD1,1,0),COLORBLUE;
STICKLINE(MACD>0,0,MACD,0.5,0),COLORYELLOW;
STICKLINE(MACD <0,0,MACD,0.5,0),COLOR00DD00;
DIFFFF:DIF11,COLOR8800FF,LINETHICK0;
DEAAAA:DEA11,COLORFFAA00,LINETHICK0;
DIFFF:DIF1,COLORRED,LINETHICK0;
DEAAA:DEA1,COLORBLUE,LINETHICK0;
DIFF:DIF,COLORYELLOW,LINETHICK0;
DEAA:DEA,COLORGREEN,LINETHICK0;
动力线:MA(MACD1,5),,COLORYELLOW,LINETHICK1;
中区:0,COLORBLUE,LINETHICK0;
主动:IF(MACD1>=动力线 AND 动力线 <=中区,动力线,DRAWNULL),COLORYELLOW,LINETHICK2;
主拉:IF(动力线>=中区,动力线,DRAWNULL),COLORRED,LINETHICK2;
翻空:IF(动力线MACD1,动力线,DRAWNULL),COLORGREEN,LINETHICK2;
AA:=BARSLAST(REF(多周期MACD趋势共振制作的方法.理论 CROSS(DIF1,DEA1),1));
BB:=REF(CLOSE,AA+1)>CLOSE AND DIF1>REF(DIF1,AA+1) AND CROSS(DIF1,DEA1);
JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));
二金:=CROSS(DIF1,DEA1) AND DEA1 DRAWICON(二金,DEA*1.04,15) ;
DRAWTEXT(二金,-0.02,' 2'),COLORFF00FF;
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,25);
VAR2:=EMA(VAR1,3);
VAR3:=VAR1>VAR2;
VAR4:=VAR1 STICKLINE(VAR3,VAR1,VAR2,1,0),COLORRED;
STICKLINE(VAR4,VAR1,VAR2,1,0),COLORGREEN;

教你如何用不到一百行代码找到kdj多周期共振点

IG507 于 2020-11-21 22:36:05 发布 798 收藏 1

作者:IG507
链接:https://xueqiu.com/1480435944/163870887
来源:雪球
著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。
风险提示:本文所提到的观点仅代表个人的意见,所涉及标的不作推荐,据此买卖,风险自负。

02-14 4050

数量技术宅团队在CSDN学院推出了量化投资系列课程 欢迎有兴趣系统学习量化投资的同学,击下方链接报名: 量化投资速成营(入门课程) Python股票量化投资 Python期货量化投资 Python数字货币量化投资 C++语言CTP期货交易系统开发 数字货币JavaScript语言量化交易系统开发 更精彩内容,欢迎关注公众号:数量技术宅,获取本期分享的完整代码,可添加技术宅个人微信号:sljsz01,与我交流 数字货币期现套利原理 数字货币市场,是近期大家关注度相当高的一个市场。在..

04-07 2455

import 多周期MACD趋势共振制作的方法.理论 tushare as ts import pandas as pd price = ts.get_k_data('300816', start = '2020-02-10', 多周期MACD趋势共振制作的方法.理论 end = '2020-04-03', ktype = 'D') price['rolling_high'] = price['high'].rolling(window = 9, min_periods =.

11-26 77

11-28 3139

06-12 217

最近迷上股市无法自拔,因为想提高胜率,所以在学习技术分析,一开始是使通达信软件写写选股公式,后面打算自己弄一个选股系统(事实证明处不大,哈哈哈)。 大概是这样实现的:首先node写了个简单的服务,每天定时跑日k线数据。然后设计了个简单的mysql表来存储这些数据,最后自己写了一些sql来分析这些k线数据,固定了一个简单的模型。但是收益效果实在一般,还需要加强学习。这次主要是简单分享一下实现的方式,也顺便做一次技术总结,并不是劝朋友们去炒股哈。 系统结构 ig507(ig507.com)是我从网上找的

04-29 1344

正弦波叠加成及波的分解1. 引言2. 特殊波形的产生3. 信号的分解与信号还原 持续更新ing,欢迎各位赞关注哦! 1. 引言 傅里叶变换是信号分析的基础,法国科学家傅里叶早在1807年提出任何周期函数都可以分解成一系列正余弦函数。同样通过这些正余弦函数的叠加可以组成原始函数,因此可以利傅里叶变换处理信号,获取有组分,进数据滤波等。傅里叶变换分为离散型数据的傅里叶级数对和连续型数函数的傅里叶变换对。 以下引自维基百科: 在数学中,傅里叶级数(英语:Fourier series,/ˈfʊrieɪ,

03-06 970

今天测试使KDJ的时候,发现talib上没有这个方法。于是,找公式准备自己实现一遍。KDJ指标又叫随机指标,是一种短线指标,它是由KD指标发展而来的。实现步骤KDJ的实现步骤主要分成三步:1、先计算“未成熟随机值”,即RSVimage.png2、求出当日的K值和D值(即计算出RSV值的3日指数移动平均)image.png3、计算出J值J = 3 * D - 2 * KKDJ简单理解1、RSV线过.

02-16 385

11-03 761

数量技术宅团队在CSDN学院推出了量化投资系列课程 欢迎有兴趣系统学习量化投资的同学,击下方链接报名: 量化投资速成营(入门课程) Python股票量化投资 Python期货量化投资 Python数字货币量化投资 C++语言CTP期货交易系统开发 数字货币JavaScript语言量化交易系统开发 更精彩内容,欢迎关注公众号:数量技术宅。探讨数据分析、量化投资问题,请加技术宅微信:sljsz01(个人号快加满,欲添加老师请从速) 价差计算的“误区” 我们在测试两个或个金融资产相.

01-10 2676